Author Topic: Giant Cod with bad chips?  (Read 3384 times)

0 Members and 1 Guest are viewing this topic.

Offline John Candy

Giant Cod with bad chips?
« on: June 24, 2010, 06:34:28 PM »
You may recall my initial enthusiasm for the low-cost 2.4Ghz R/C units  (at that time around 25GBP but now a bit more, thanks to the weaker Pound) which were appearing from China under various brands....see previous thread on this board.

I had been looking for a second RX unit for my Futaba 6EX but at around 80GBP the cheaper units looked to be a better buy.
I purchased two Giant Cod units (which I shall refer to as 'GC' hereafter) and a Planet T5 (the T5 being about 45 GBP at that time, compared with 160GBP for another complete Futaba TX/RX unit package).

Of the two brands, Planet T5 has a far superior finish with digital voltage display (the GC simply has a red LED which flashes when the TX batteries are getting low).
The GC unit  requires 8 x AA batteries, whereas the T5 requires just four.

Now to the problems : The GC RX units have a button on them which 'binds' the receiver to its designated transmitter. This is said to be a 'once only' operation which binds the units for life (unless you wish to switch to a different transmitter, in which case you can repeat the 'binding' procedure).
When both units were new I followed the binding procedure without any problems. The units were then repacked in their boxes until the first was required ....for installation in my LNER class N5/1.
When switched on the unit would not operate : The RX was given a repeat of the binding procedure and it started working.
I thought nothing of this, until I next came to use the unit and again no response.
At first I thought the wiring or some other component in the loco had failed but swapping the R/C components for the Futaba unit and then the T5 unit quickly disproved that theory. I then tried using the second GC unit but again no response : The binding had failed.

I have now carried out further tests and find that the 'binding' is lost on both the GC units everytime the power is cut. Furthermore, switching back on and attempting a 'rebind' does not work unless the unit is left switched off for several minutes. This is no good for my locos, since it means dismantling the bodies to access the reset button.

I have just searched Google and found an aero modelling site where four crashes were reported as a result of Giant Cod receivers 'locking out' the transmitters while in flight.

Anyone else have experience of these units (I know 'Cabbage' is using one in his latest creation)?

The T5 and Futaba have no similar problem although the T5 exhibits some quirky behaviour which may be down to some setting which I have not yet mastered.
The throttle control when in the centre 'off' position is not 'off'! The trim control adjustment placed at its extreme lower position restores the centre 'off' BUT when the transmitter is then switched 'off', with the loco stationary, the loco then starts to move....weird or what!

I guess the old maxim, "You get what you pay for", rings true!

P.S. Have since sorted the T5 problem : The Mac5 was still synchronized with the 'off' setting of the 'GC' TX unit and has now been reset and the T5 is performing faultlessly.
« Last Edit: June 24, 2010, 08:25:54 PM by John Candy »
My fellow Members, ask not what your Society can do for you, ask what you can do for your Society.

Offline cabbage

Re: Giant Cod with bad chips?
« Reply #1 on: June 24, 2010, 09:59:13 PM »
I have no real problems with either of my G/C systems -as far as I know? I am a little busy elsewhere at the moment and I have not really had chance to hard wire the Krokodil -it is living with "flying cables" blu-tacked onto the roof. I have found the "click stop" channel 3 to be a little fussy as a throttle and I am thinking of using channel 4 for this. Although it does remove the fixed setting I think it returns the human element to the driving! I have been updating my web site entries on the Krokodil but not the forum thread -sorry about that!

For reasons that have to do with my, "personal design philosophy", I always use a separate battery pack with 4AA NiMH cells to power the Rx unit from -rather than take power from the main SLA power cells or the BEC 5V output from the ESC. Wether there is any co-coupled interference from the large amperage fluxes that feed into the Rx from the main SLA power cells -I cannot say. All I know is that I seem to get a better behaved model when I do so.

regards

ralph

Offline Moonraker

Re: Giant Cod with bad chips?
« Reply #2 on: June 25, 2010, 12:50:55 AM »
I'm using a Spectrum 5 channel unit in my GWR steam railmotor and also in a "Coffee Pot" steam railmotor I built a while ago. Range is excellent and links everytime within a couple of seconds of start up. Spectrum seems to have the best reputation and has certainly been totally reliable for me.

I saved a few quid by going to a model aircraft shop and buying the transmitter and receiver from their stock of helicopter spare parts. Total cost was about 60GBP.

Peter
Peter Lucas

Offline John Candy

Re: Giant Cod with bad chips?
« Reply #3 on: June 25, 2010, 07:27:04 AM »
"Patience is a virtue", I remember being told when young!!

Following Ralph's suggestion of using an independent supply (instead of BEC) I tried again with the Giant Cod units, this time out of the loco and coupled to servos.

Switched on but still no response : Left the unit sitting switched on while I checked my email.
Suddenly a 'buzz' as one of the servos centred itself .... the unit was working.

Tried switching off and on a few more times and, sure enough, it worked.
It is simply a case of being patient....the TX and RX seem to take from 30 seconds upwards to recognise each other (guess it was the almost instant response of the Futaba and T5 units which misled me to assume the GC units would be as fast).

Anyway, the T5 unit will now stay in the N5/1 and the GC units will go into my three live steam LNER Y6 tram engines where they will be easily accessible, should it be necessary to use the "bind" button (that is if I ever see them again.....now in their fourth year with Lynx Model Works for a re-wheeling job which was supposed to take "2 to 3 weeks").

Peter,
How is the GWR railmotor progressing?
I seem to recall the quality of the GRS kit for the auto-trailer body was less than satisfactory but assume you overcame that problem?

Photos of the 'Coffee Pot' and the GWR car would be nice, when you have a moment to spare.

Regards,
John.

My fellow Members, ask not what your Society can do for you, ask what you can do for your Society.

Offline Moonraker

Re: Giant Cod with bad chips?
« Reply #4 on: June 25, 2010, 01:26:02 PM »
John,

The power bogie for the GWR steam railmotor is finished and work is in progress on the coach body. Had to do a fair bit of kit bashing but am getting there. I'm busy installing wood panelling in the coach right now and will be starting on the seating next week. I will post some photos of the power bogie shortly and am doing an article on it for the newsletter.

The "Coffee Pot" is a hundred year old railmotor which runs on the 3' 6" Pichi Richi railway in South Australia. I modelled it for G Scale on 45mm track. The loco portion is based on a Roundhouse kit and is oversize compared with the prototype. The real thing has a tiny boiler and minature walshearts gear driving 2-2-0 wheels. However the coach unit is accurate. There was an article on it in garden Rail magazine a couple of years ago which I can email anyone who wants it. Photo is attached if I can figure out how.

Peter
Peter Lucas